Why doesn't the "Go to first new post" button work?

Usually, when I click on it, it just takes me to the first post, even if I’ve scrolled through the thread many times, with the most recent being at, say, 26 posts.

For the record, the “go to first new post” link is working fine for me.

Where do you find such a button?

Blue button on the left of new posts. It looks like the symbol after your name in the quote above, except the arrow points down.

Thanks, BigT!

Next to the date of every post is a blue or an orange square. The orange squares are “new posts” so the “Go To New Post” button should go to the first orange square.

(Should you click the regular link instead of the blue down arrow icon, there is a “Go To New Posts” text link at the top of each page, if there are any orange squares in the thread)

Sometimes, possibly due to caching, the orange squares won’t change to blue as immediately as you might expect. Sometimes they will change sooner than you’d expect. Sometimes the “Go To New Posts” button will take you to part way through the orange squared posts, accurately to the newest post despite the previous orange squares remaining.

I think it’s a quirk of caching that may never be resolved.

It’s not working for me, either, and it hasn’t for a while.

Does it have something to do with the ads? Are you forcing us to see the ads at the top of the page every time?

FTR, this used to work just fine for me, and now it does the same thing as the OP.

It works, but not the way it used to, or is supposed to.

It used to know where you had read to in a thread, even if you’ve been on the board since but not visited that thread. Now, it just goes to any posts since you were last on the board, period. So, if you visited the board, but didn’t visit that thread, it thinks you read those posts. Very annoying for fast moving threads. And not how it’s intended to operate.

It’s especially annoying as it did used to work correctly. I have brought this issue up before.

Alas, no response. Sigh.

This is the way it works for me. I don’t remember it ever behaving differently. Always thought it was a weird and kinda useless feature until I tried it on other boards.

I have cookies enabled in Firefox, for what it’s worth.

Which broswer are you using? It’s most likely a caching or cookie issue with your browser.

Try a different browser, see if it still happens.


I will assume that you didn’t skip me on purpose to hurt my feelings, but instead it was just an oversight. :smiley:

I will report back with my findings. FTR, I use google Chrome as my default browser.

I’ll try both explorer and firefox to see if it makes a difference. Thanks for the suggestion.

I just tested this with IE8, and it worked as it is supposed to.

So for me, at least, it was indeed a browser issue.

Thanks for the suggestion, xash.



In Chrome, go to Tools/Options/Personal Stuff/Browsing Data, click on Clear Browsing Data, select Empty the Cache and Delete Cookies, choose Clear Data from Everything, click the Clear Browsing Data button, then close and restart Chrome. Note that this will probably affect your experience on other sites you frequent, as you might lose some saved settings and have to re-enter passwords, etc.


nevermind. :slight_smile:

Any suggestions for Firefox users?

Y’know, the ones not savy enough to be switching up browsers, etc?

In Firefox, go to Tools/Clear Recent History/Time Range to Clear: Everything/Make sure Cookies, Cache and Active Logins are checked. Then click Clear Now. Note that this will probably affect your experience on other sites you frequent, as you might lose some saved settings and have to re-enter passwords, etc.


Thanks Xash, I really appreciate the effort. (And the small words too!)

I’ve had this problem intermittently over the years, but now it’s been happening every single time I’ve been on since Sunday (inclusive); enter the forum, go to GQ, all threads have their read tags reset to the last posts. Annoying as hell.

John DiFool, please try the above solutions.


Okay thanks, didn’t see the new thread (or didn’t see that it was talking about the same thing). As I noted in another thread, I recently was forced to switch my Windows account from administrator (due to my obtuseness), so yeah.