Can't access second page of thread...

…after finding said thread with Search.

I keep getting this error message

This doesn’t happen when I get to the thread from the active board page. Only from a search results page. The search results page never provides links to the second and subsequent pages of a thread, only the first one. This may have something to do with it.

Hmm. That’s unusual.

Haven’t seen this before.

Anyone else encountered this problem?

BTW, what browser are you using? That might give us a clue as to what’s going on.

your humble TubaDiva

I’m not getting that error message, but when the hamsters on taking their coffee break, I’m able to access the forums page relatively quickly, it takes a little longer to access the first page of any forum, it takes longer than that to access the first page of any given thread and it takes MUCH longer to access page two (if the thread goes beyond page two, it takes even longer.)

This probably has no bearing on Jomo’s issue. But just in case.


That sounds like an HTTP Error 400. Sometimes these errors pop up when a space is in the link (or an interpretation of a space).

Is there a “%00” in the link (without the quotes)?

’ ’ would be %20. %00, while it would screw up the link as well, is a different character.

The thread’s link on the search results page, and the second-page link in the thread, could you right-click on them and copy their URLs to the clipboard to post them here? Or compare yourself if anything strange happens to the link except for the added &perpage=50&pagenumber=2.

A link from the search page has a parameter added, specifying your query words to highlight in the thread. Maybe there’s something in there that confuses the board software when it tries to generate the thread’s second-page link with it. Perhaps characters with accent marks get parsed to spaces or somesuch, the board doesn’t seem very bright on this part.

Funny: didn’t create an error, it displays the complete thread, but without the post text! :slight_smile:

Actually, that’s pretty cool.

Damn, that’s weird. For some threads, it’ll be an improvement

For those who are curious, %00 is the null character, which never shows up as anything no matter what you’re doing. It’s used internally by many programs to mark the end of a block of text.

I got curious, and looked at the source code for that page. The post text is very definitely not there.

So as a further experiment, I tried highlighting %20, the lowly space character. That didn’t do anything unusual. It’s probably displaying all the spaces in red, but since they’re invisible anyway, it doesn’t matter.

Here’s something interesting. I tried to highlight the character ‘a’. It only marked it when it was a complete word, which is not what I was expecting. Then I bumped it to highlight the letter ‘b’ as a complete word to see if that would do anything. Nothing was highlighted, but the post text was there.

After that, I decided that I had placed enough strain on the poor server, and quit.

I guess it accepts the parameter, but then translates it to a nullstring of zero length. Of any string, the empty string is a subset. So when the software runs through the posts looking for matching words to highlight, the whole post matches, and it gets replaced with that string, containing nothing.

This might be a bug that’s already been fixed, we’re a couple of upgrades behind.

In any event, I’ll report it to vB, see what they have to say about it, if anything.

your humble TubaDiva

You know how the broken appliance starts working again by itself once you’ve got the repairman there? This is sort of like that. I did some more searches, to show you an example, but the bug didn’t happen again. But honest, it has been happening a lot, just not every time.