Doing something wrong creating links

When I want to make a link, I hit the “linky” icon (hell if I know how to describe its appearance–a blue-green octogon wearing a brassiere?) and paste in whatever url I want to link to–invariably, what it does is to make a link from which I need to edit out an extra “//http” and a whole 'nother extra url. Anyone else ever get this?What am I doing wrong?

Might as well create a flawed link to illustrate:


The above line is what I get when I try to create a llink using the icon.

Which gets me to here:

Not where I was trying to go.

Here’s what I can surmise you’re doing wrong:

When you hit the globe with the link chain (how’s THAT???) a box comes up with “http://” already highlighted.

At this point you can do one of two things: If you are going to paste a link in the box, leave the “http://” highlighted and hit CTRL-V to paste. This will erase what’s in the box and replace it with your link.

If you’re going to type in a link, click and unhighlight the “http://” then type your URL in without adding another “http://”

If you leave both of the "http://"s in, it will redirect to your Roadrunner page.

Am I even close, PRR?

The dialog you paste the URL to by default has the HTTP:// part already there. Unless you overwrite that, either by deleting it before you paste your URL or highlighting it and pasting the URL over it, your created link will have the duplicate HTTP:// present.

I always get an extra http when hitting the link icon.

But I’ve never seen one of these:

Are there bras everywhere you go? :dubious:

No, some places just have tits swinging freely right and left.

Rico, any thoughts why I’m getting a duplicate url as well? (See example posted above.) I’m not geting what the purpose of the redundant “// http:” is, if I have to begin by erasing it. Don’t most people have a url cut-n-pasted with the “//http:” part already included?

I’ve never understood it either, personally. It’s just the way this board software is.

I’ve found if you leave it highlighted when you paste the URL into it, it erases the “http://” that’s there and puts only your link in. Make sure you don’t click in the box, that will unhighlight it and you’ll end up with two.

And something I thought of after posting my first response: The reason it became a Roadrunner search page is, well, you’re on Roadrunner cable! I’m on Qwest DSL, so when I click the first link it takes me to a Qwest search page. It’s basically a 404 error (page not found) so it defaults to your ISP’s search page, if your ISP has it enabled. Yours and mine apparently do.

404 is an HTTP error. That error is not generated by HTTP, but by RoadRunner’s DNS servers hijacking failed requests and therefore breaking the Internet. People at RoadRunner should be drawn and quartered for this.

Oh, you better be extra nice to me. At this very moment, I’m working on setting up and testing 6 static transfer switches to be shipped to one of their data centers. We wouldn’t want one of them to fail[sup]1[/sup] unexpectedly and disconnect a bunch of subscribers, now would we? :stuck_out_tongue:

[sup]1[/sup] Joke, for the humor-challenged.

It occurs to me that you might be talking about the text that now appears between the URL tags…that threw me the first time I saw it, too. When you use the Link button to link to, say, Google, you end up with this:


vBulletin assumes you want the URL itself as the default “blue text”, but if you don’t, the middle text is selected so that you can immediately type a new one. For example, if I use the Link button, fill in “”, and then immediately type “Google” (without repositioning the cursor), I get:

[noparse]Google[/noparse], which translates to Google.

Is that what you meant, perchance?

I think so. I’ll try it:

is what I get when I type “Rosenbaum” in the link box. It doesn’t look right, so I suspect I misunderstood you.

No offense meant prr, but how can you have been around the Dope since 2002 and not have sussed that out by now? :smiley:

Ok, follow these steps.

  1. Copy the URL.
  2. Press the Link button.
  3. Paste the URL in the box, replacing the “http://” that’s already there.
  4. Press OK.
  5. Type “Rosenbaum”.

That leaves you with this: Rosenbaum

Make sense now? :slight_smile:

To be fair, the user interface in this area did change quite drastically with the recentish upgrade.

Great. That works with a little fiddling (I’ve changed your steps to make more sense of the order, and to clarify what will happen if I type “Rosenbaum”.) Essentially, it wasn’t clear to me that typing or pasting both the URL and the word I want to appear would automatically erase the highlighted portion(s) in the box. Thanks.

  1. Copy the URL.
  2. Press the Link button.
    2a. delete the “http://” that’s already there.
  3. Paste the URL in the box,
  4. Press OK.
  5. Type “Rosenbaum” which will automatically write over the the second URL that would otherwise appear in the link.

That leaves you with this: Rosenbaum


If you just paste the URL after step 2, step 2a will happen automatically, as the http part is already highlighted.

In order to paste my url, I have to first click inside the box, which erases the highlighting. Am I misunderstanding your post?

You do not have to click in the box. Click the URL link and then click paste (ctrl-v works for me in this scenario, I’ve never tried clicking paste in the edit menu).

Try it. You’ll see what I mean. I’ve never clicked control-v in my life, but maybe that’s the way to go here.


I did this by following my system:

I copied the URL I wanted to link to
I clicked the URL link button
I did ctrl-v
I typed “Yahoo”


I did this one (above) this way:

I clicked the URL button
I typed
I typed “Yahoo”

Both ways worked.

One clarifiaction to my above directions–

I did click “ok” after pasting/typing the URL and before typing the text I wanted for the link name.