Don't let Firefox update to 3.6.16 New Tabs are broke

I’m just about fed up with firefox. :smack: The crazy thing did an auto update this morning.

Now I can’t open a new tab. :mad: :mad:

I’ve tried all three methods. ctrl-t, file new tab, and of course the new tab button on the tab bar.

nothing works. It just ignores it and keeps the one tab open.

I did discover applications can still open a new tab. When I clicked firefox help, it opened in a new tab.
right click, and opening a link in a new tab works too. But the normal way of opening a new tab is broke. What kind of quality control is this??? Why in the hell didn’t they beta test before releasing this update?

I’ve turned auto update off my other pc. Now I have to rush to the office and do the same to 18 other pcs before they are fucked up too.

Anyhow, a word of warning. Stop this update at all costs.

3.6.16? It’s up to 4.0 now.

Ahh, my PC at home auto-updated to 3.6.16 this morning too, and everything’s working fine.

Just sayin’.

My copy of Firefox just updated itself to 3.6.16 this morning, and new tabs are working just fine for me.

Who knows?

Yes, but you have to specifically download that version. 3.6.16 is an automatic update of Version 3.

Just install 4. It works great.

Try disabling any add-ons and see if that fixes it.

Firefox has been driving me crazy for the past month. using 60% of my processor. Not always shutting down. I often have to kill the firefox process. It’ll be eating up all my memory (1 gig).

The misery started with that darn plug in container.

Now this morning they break new tabs with this new release.

I’m going to completely uninstall Firefox and reinstall. See what happens then.

Got FF4-damnfast, works like a dream.

:smiley: great idea.

I got tabs back. ctrl-t, file new tab, and the new tab button work again. Now, I have to start turning plug ins back on until it breaks.

Earlier this morning, I did search for any updates to my add ons. So I know they are up to date.


Count yourself lucky you aren’t using OpenSuse 11.3: not only does Fx increase memory non-stop ( and not release memory when tabs are closed until I have to kill it ) but XOrg — the video manager — tries to match Fx in memory usage. XOrg can’t be killed except by closing the session… But yeah, CPU usage is mainly down to Flash.
As for New Tabs, they are working on 4 fine, but unfortunately Mozilla has a habit of copying Opera’s bad ideas and a time ago moved to the little cross at the end of the tab-strip, which is just annoying ( like most of Opera ). There was an extension to remove this behaviour, but it is incompatible with 4, and Fx won’t, as previously, offer a New Tab icon in customization…

Everything is ok now.

I uninstalled a few add ons I didn’t need. A couple had been added that I didn’t want. GOM player had snuck Ask& GOM toolbar into firefox. I have a Microsoft Framework Assistant grayed out. Can’t uninstall, enable nothing. Says it’s incompatible with this ver Firefox. That was junk anyhow I got after doing the Framework upgrade.

Not sure exactly which add on screwed me up. At least it’s working now.

I’ll go to Firefox 4 after No Squint and Download Helper have updates for them. I absolutely must have No Squint. I get headaches trying to read the web without No Squint. I keep it set on 120%

Why do you dislike the “new tab” button? I find it pretty convenient, being more a mouser than a keyboarder.

Trying out FF4 at work before committing to it at home (which is where I do most of my work), liking it so far. Anyone notice any memory/CPU leaking with FF4? It wasn’t a frequent problem with 3.x, but I did have to kill it occasionally.

One thing I don’t like about the newer versions is that it seems if you click a link to open in a new tab, it puts it next to your current tab, instead of all the way to the right of your tab set like it used to. I haven’t been able to get used to this – I don’t switch to the new tab when it opens, so I always mouse all the way to the right looking for it, before I notice that it’s back in the middle. Grrr. Is there a setting to change this?

I hate that too. Here’s the fix:

I preferred the old way of mousing to a new tab icon.

I’ve been on Fx 4 beta for a year, so can’t compare; but Firefox always has memory problems. Still the greatest browser created in the last 500 years though…

To be fair I think some of my memory loss, despite the usual about:config tricks, may be due to Auto-Pager extension ( on image sites, naturally opening several heavy image pages below ), but I can’t imagine using a browser without it.

Try extension Tab Utilities.

I updated to 4.0 yesterday. Big mistake.

I prefer my tabs along the bottom of the screen, not the top. So do a lot of users, but despite endless pleas to Mozilla, they have never added a toggle switch. Instead, you have to create and edit a custom script file called userchrome and paste special code into it. If you’re not geeky enough to know how to do that, you’re screwed.

So anyway, I updated to 4.0, swore when I saw my tabs way up at the top of the screen (again), then went and did the fix, again.*** It doesn’t work with 4.0***. :mad: :mad:

I had to backup all my prefs, download 3.6 and reinstall.

Fark you Mozilla, for wasting over an hour of my time. You suck.

I’ve never heard of anyone wanting that, but as I suspected Stylish has a script for doing it in 4.
Tabs on bottom.

You have to install **Stylish**as an extension first, but for scripts you just click on install. I mainly use it to centre images.
Also that will cover your status bar, but 4 dropped the status bar anyway sadly — though it can be replaced with the weirdly optional add-ons bar ( via customization ) at the base to look tidy.

I noticed that FF 4 has a kind of dynamic status bar: it only appears when there’s a message that something is happining.

Here’s a good post on how to get Firefox 4 looking back like Firefox 3:

Ask any Opera user, tabs on bottom are the default.

Why is that so unusual? After all, tabs for all open windows programs are displayed on the bottom of the screen, not the top. Tabs on top are not intuitive at all.

Um, the** very first thing** I do on installing any OS is to move the Taskbar to the top…


Then switch to Classic View for the Start Menu. Can’t stand Slab menus or diving down for tasks.