Ignore User not working

Just tried to add a username to my Ignore list and kept getting “Please select a timeframe”, even though I had, in fact, selected a timeframe.

Side note: Turning off my adblockers in an attempt to get the thing working revealed that ads are not blocked for me despite being a charter member. Discourse needs to get off its thumb about that.

I can’t reproduce this; I just ignored a random user for a week. How are you initiating the ignore? From the user’s profile page, or from your personal preferences page? (both should work for the record)

Personal preference page.

I’ve just cleared my cache and browser history and will be trying again.

Still can’t repro, unfortunately. I am in Chrome / Windows 10. I am able to ignore a random user for a week either via their profile page, or my own preferences.

(Also I feel kinda bad, I just ignored a user who posted for the first time in 9 years :scream:)

One thing to try, depending on how pernicious the problem becomes, is to use a different web browser, one you don’t normally use, to rule out weird browser settings / plugins / customizations etc.

I have a ton of plugins, yes. Chrome/Windows 10 Pro. Here’s what I’m seeing.

I don’t know if I can ignore from the user’s page; their profile is private.

I did also try removing one or two now-banned posters in case there was a limit. That not only didn’t help, but I can’t add them back.

I am currently using Privacy Badger, Disconnect, Ad Block Plus, and MalwareBytes Browser Guard. Whitelisting this site in those extensions brings all the ads back, which I do pay not to see, and still doesn’t let me ignore the user.

Rebooted. It works. Dunno what I did, but apparently I did it wrong and now I’m doing it right. Close thread if you feel like it.

No need, nor do I have power do to so (not a mod here, more like a technical janitor). Glad it’s working now!

I’ve found that the error message in this case doesn’t pinpoint the root error. When I got a “please select a timeframe” error even though I did select a timeframe, I’ve found that it was because the user wasn’t “confirmed”, like when you type ahead and the system automatically finds a user and you select it.

The system still needs to find the user even if you type in their entire name. So after you’ve typed the name you need to wait for the system to pop up with the user name under the text and select it. Then it should allow you to select a timeframe and ignore the poster.

So I was typing too fast and then clicking too fast?

Figures. Thanks for figuring that out.