iPad woes - ideas please?

My brother sent me this description of his problems with his iPad. I use one only as a “cash register” at work, and I can’t help. Can you?

My iPad mini is stuck showing that I should plug the iPad in to iTunes. It will not update to iOS 8.1.3 and will not restore. Here are the pop-up boxes I get when I plug the iPad into iTunes:

There is a problem with the iPad “iPad” that requires it to be updated or restored.
The problem may be fixed by updating your iPad, which preserves your settings and content. However, if updating doesn’t, it may be necessary to click Restore, which erases all settings and content. If you backed up this iPad to this computer or iCloud, you’ll be prompted to restore the backup onto the iPad.
Choice: Update or Restore (clicked Update)

If your iPad can’t be updated, you will need to restore it to its factory settings.
iTunes will update your iPad to iOS 8.1.3 and will verify the update with Apple.

The iPad “iPad” could not be updated. An unknown error occurred (3014).
Choices: Ok or Continue (clicked Ok)

Your iPad can’t be updated; you must restore it to factory settings.
If you previously backed up the iPad, click Restore Backup after the restore process completes.
Choices: Restore or Cancel (clicked Restore)

Asks if you want to Restore and Update or Cancel. (clicked Restore and Update)

The iPad “iPad” could not be restored. An unknown error occurred (3014).
Choices: Ok or More Information

I have also twice tried uninstalling iTunes and reinstalling it. I have twice opened Notepad, gone to C:\Windows\System32\drivers\etc, opened HOSTS, and tried adding “ gs.apple.com” to bottom. You are then supposed to click on gs.apple.com which is supposed to take you to the Cydia homepage, but my computer doesn’t go there. The HOSTS file appears as though it’s supposed to have a last line saying “ localhost”, but mine doesn’t. I don’t know if that makes a difference. I’ve tried typing that in too where it is shown in the instructions, but nothing different happened. I have also tried holding down the home button and power button for ~10sec, then releasing the home button and continuing to hold the power button for 5 more seconds. I’ve done this about 10 times and each time it goes back to showing that I should plug the iPad in to iTunes.

It’s stuck in recovery mode. Hold down the home button while plugging it in.

It’s not an iPad problem per se. What he has is a jailbroken iPad, and the iPad can’t reach the Apple server (that’s what error 3014 is apparently.) He’s trying to redirect gs.apple.com to (the Cydia page) so his jailbroken iPad can be updated.

So the questions really is how to properly edit the hosts file so gs.apple.com. redirects to I’m not sure why it’s not working for him, because that seems to be the correct procedure, but it’s been years since I’ve worked regularly on Windows.

Wait, let me revise the above. It’s also possible your brother found the 3014 error Googling around and does NOT have a jailbroken iPad. If he does not have a jailbroken iPad, the HOSTS editing is meaningless and should not be done. Remove that cs.apple.com line from the hosts file. It’s not supposed to be there if you have an iPad running Apple software on it.