Windows 2000 & Cable modem

I will be honest… I don’t know much about 2000 at all…

here is the deal… we just had a cable modem installed. It works fine hooked up to a XP computer, but when I connect it to a 2000 computer it does not work.

The TCP/IP settings are the same on both computers… (obtain automatically, DHCP enabled) all that fun stuff.
I have tried to relase and renew my address, but that doesn’t work.

but it is strange, I can ping www.yahoo.com and get a responce…

but I can not get any pages to load.

my connection status is also strange… I do get up to about 1,000 packets sent and received… a very small number… but that means there is a connection there… correct?

I have also tried 2 different LAN cards.

ok… If you have any ideas… PLEASE help… this is frustrating. thanks.

Assuming IE, go to Tools -> Internet Options -> Connections -> LAN settings and make sure the settings mactch…

yeah they are the same…

Are you sure that the cable modem itself will work with Win2K? If it’s not on the Hardware Compatability List (check Microsoft’s website), then you may have weird issues like this.

Here’s something to try: go to the modem’s properties, and you should see a tab that says “Query Modem,” click that, and see if it shows you any weird messages… that might give you an idea whether the trouble lies with the modem or not.

Sorry, the “Query Modem” button is on the “Diagnostics” tab of the modems properties.

Sorry, Astroboy14, but “query modem” has nothing to do with a cable modem.
merge:

All right. So you can ping out using the domain name, not the IP address, yet can’t load pages in your browser.

Your setup goes LAN card to cable modem, right? Are you using a switch or hub? Any USB involvement?

  1. Indulge me in this one: type 66.218.71.198 into your browser address box and hit Enter. It’s the IP of Yahoo.

  2. Run a command prompt on both machines. Type IPCONFIG /ALL (case insensitive, FYI) and hit Enter. Compare your DNS and WINS addresses on both machines.

  3. Hi Opal!

Please let me know what you’ve found.

So “Query Modem” is only for an internal modem then? Ah… good to know!

Well, no, not exactly. The modem this Control Panel applet generally applies to is the “dial-up” analog modem (MODulator / DEModulator), of which there are external varieties.

A “cable modem” is a different animal entirely. And IMHO, to avoid confusion, it should never have been called a modem in the first place.

You say ping works… does any other service (ftp, telnet, mail, etc) work? Since you can ping yahoo, DNS seems to be working… I’m leaning towards IE being misconfigured somehow.

Re: Dial up modems - you can interrogate and set stuff directly on your modem with any low-level com program… I think Hyperterminal would work. Modem command set

Merge,
How are your XP and Win2K PCs connected to your cable modem? Do you have them both connected at the same time through a router?

If you’re not using a router, but connecting both to the modem using a hub instead, then you’re probably getting some sort of IP conflicts as your modem is set to assign a single DHCP IP address.

ok… sorry for not getting back…
I took a long weekend, anyway…

Mr. B
I did ping 66.218.71.198
It worked fine. my average ping was 78ms.

The DNS and WINS is the same on both machines.

I am not hooking them both up at the same time. I am just testing one with the modem, and then the other. \

any other ideas? anyone?

I am thinking of just upgrading to XP, but I called the software company that we have been using, and they said that their software will fail if we upgrade, and we will have to back up our files, reformat the computer, and then install XP, and then the software again…

OK. Well, actually, I’d hoped you would type the IP into your browser address window and hit Enter.

Please let us know the results.

There should be no reason to have to upgrade the Win2K box to XP. When you do an ipconfig on the Win2K box what do you get back?

merge: please try the “Browse by IP” as above. I think I know what’s up.

New Jersey. Is your service provided by Comcast?

Ok…
Whistkey-Hotel, I agree with you… there should be no reason… but I don’t know 2000 at all… and ipconfig comes up with the same thing on both computers.
XP works, 2000 doesn’t…

Mr. B,
sorry… I read your other post too quickly… I tried just using the IP… no luck…
I am using Comcast…

Great! I do believe the problem has to do with your second machine’s MAC (Media Access Control) address.

When Comcast sets up internet access, they register your machine’s MAC address as an “authenticator” for your account. In California, for example, if you use another machine on the same setup, Comcast bills you an extra ~$10 a month. Could be different in NJ; they could simply cripple browse requests from other MAC addresses.

The simplest thing to do is to buy a network switch/router, specifically one that allows you to clone the MAC address. You’ll then be able to use both computers at the same time.

Thanks,
I will give that a shot tomorrow… I will probably just bring in my router from home to test it out… hope it works… thanks again for your help…

Just make sure you can clone the MAC of your current, working machine. Big caveat.

Good luck! :slight_smile:

As it seems there’s something funky with IE, I’d try upgrading to the latest IE. of course that means getting internet access, likely by slow dialup, blech.

By the way, I assume IE worked before on dialup?

Strange all around.

You don’t have a switch or something between the PC and the cable modem that might have cached the arp addresses? Probably obvious, but reset the cable modem and anything in between.

IT’S OFFICIAL: THIS BOARD SUCKS. I’m so tired of retyping posts, and waiting forever for responses.

Where was I? Oh, yes. While I typed the last post, Mr. B won the prize. I ran into that with Comcast in Calif as well. One thing that may be important: They allowed me to register multiple MAC addresses. Their rule was that you can only use one computer (they give you one IP address), but it can be one of many computers.

Of course, you’ll want to get a router to have multiple machines.

Now copying this text in case I have to retype.